ManageBac outage
Incident Report for Faria Education Group
Resolved
ManageBac is up and running again. Thank you for your patience as we resolved the issues on our end!
Posted Sep 19, 2019 - 18:44 UTC
Investigating
We are currently experiencing unscheduled downtime on ManageBac. We are working to resolve the reported issues as fast as possible. We will let you know as soon as we know more.
Posted Sep 19, 2019 - 18:26 UTC
This incident affected: ManageBac.