ManageBac partial outage
Incident Report for Faria Education Group
Resolved
The datacenter is back online.
Posted Jul 23, 2019 - 11:51 UTC
Investigating
ManageBac is experiencing downtime of US datacenter related to deploy new release. We are working to get it up as soon as possible. Thank you for your patience!
Posted Jul 23, 2019 - 11:46 UTC
This incident affected: ManageBac.