Openapply China region issues
Incident Report for Faria Education Group
Resolved
OpenApply downtime is over. We are back up and running.
Posted May 29, 2019 - 02:16 UTC
Identified
We are experiencing issues with Openapply in China region.
Posted May 29, 2019 - 01:54 UTC
This incident affected: OpenApply.