ManageBac partial outage
Incident Report for Faria Education Group
Resolved
The datacenter is back online.
Posted Jul 29, 2019 - 10:16 UTC
Identified
ManageBac is experiencing downtime of US datacenter related to deploy new release. We are working to get it up as soon as possible. Thank you for your patience!
Posted Jul 29, 2019 - 10:12 UTC
This incident affected: ManageBac.