Keybridge maintenance
Incident Report for Faria Education Group
Resolved
KeyBridge up and running.
Posted Jul 22, 2019 - 16:47 UTC
Identified
KeyBridge is experiencing downtime related to a database maintenance. We are working to get it up as soon as possible. Thank you for your patience!
Posted Jul 22, 2019 - 16:04 UTC
This incident affected: Keybridge.