Atlas Login is Down
Incident Report for Faria Education Group
Resolved
We are continuing to investigate this issue.
Posted Feb 05, 2020 - 01:24 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2020 - 01:24 UTC
Investigating
We are currently investigating this issue.
Posted Feb 05, 2020 - 00:55 UTC
This incident affected: Atlas.