ManageBac is down.
Incident Report for Faria Education Group
Resolved
ManageBac is up and running again. Thank you for your patience as we resolved the issues on our end!
Posted Nov 25, 2019 - 08:19 UTC
Investigating
We are investigating intermittent downtime related to a gem update.
Posted Nov 25, 2019 - 08:07 UTC
This incident affected: ManageBac.